VMware ESXi 5 whitebox NIC support

I tested the following NICs in my VMware ESXi 5.x whitebox server at home:

NIC Recognized by VMware ESXi 5 Listed in ESXi 5 as
Intel PRO/1000GT Desktop Adapter PCI Yes Intel 82541PI Gigabit Ethernet Controller
Realtek RTL 8111E Yes Realtek 8168 Gigabit Ethernet
Intel Gigabit CT Desktop Adapter PCI-e Yes Intel Corporation 82574L
Intel 82579 Gigabit LAN controller No

You need the make a customized ESXi 5 ISO or VIB file.
This is a not supported configuration!
Intel Corporation 82579V orIntel Corporation 82579LM

To add the Intel 82579 chipset, create a customized ESXi 5 ISO.  This is very simple because some people have already done the hard work.

Here are the steps:

1. Download ESXi-Customizer (create by Andreas Peetz) found here.

2. Download the driver (created by Chilly) found here.

3. Start the ESXi-Customizer and follow the 3 steps:

2011-12-04 17h03_20

And you are ready to install the customized VMware ESXi 5 ISO. The ISO supports the Intel 82579V and 82579LM NIC(s) found on many whitebox motherboards today.  Possible future updated version(s) of the driver can be found in the following post.


80 Responses to VMware ESXi 5 whitebox NIC support

  • Jesus says:

    Installed ESXi 5.1 & though via local CLI I can see the two nics (Intel 82579LM and 82579V) using lspci, I only have ONE network adapter via the System Customization interface on the local server. vSphere client also just shows me ONE network adapter. I have tried using the e10001 vib file others have used for solving this issue and when I use the command “esxcli software vib install” to install it, I always get the same vmware error saying that file not found in depot, even though it is locally present in both the datastore1 and the /var/log/vmware/ directories!
    Going really crazy with this. It is the reason I love windows and hate linux. I can do anything in windows, but in linux, it is a nightmare hehehe.
    Any help much appreciated!

  • Keith Liew says:

    I got this error when customizing the driver
    Fatal Error: Error uncompressing OEM.tgz

    Please help.

  • Antonio says:

    After knowing that ESXI 5.0 does not support the Intel 82579V NIC, I created a customozed version of ESXI 5.0 using your procedure.
    I was able to install the customized version but when and the server rebooted in order to run ESXI 5.0,
    I got the following message:

    The system has found a problem on your machine and can not continue
    could not populate the filesystem: Boot image is corrupted

    My system configuration is:

    MotherBoard: Asus P9X79 PRO
    CPU: I7-3280 3.6 GHZ
    Ram Memory: 32 GB
    Hard Drive: 1 TB Seagate

    Any help in order to install ESXI 5.0 on this machine will be appreciated

  • langxingming says:

    I want to hold a e1001e.tgz,but I can’t download it,Can you help me?

  • Swilky says:

    Thankyou so much!

  • Johan says:

    Thanks for the information. ESXi 5.0 is running on HP Compaq Pro 6300 with INtel 82579 NIC.
    Just rename e1001e.tar to e1001e.tgz after downloading!

  • Arno says:

    is there anyone out there where the realtek 8111e is also not recognized? I have a B75ma-p45 motherboard but the network card does not show up??

  • MRJ says:

    Does this also work with 5.1? After creating the installer and installing, system reboots with purple error screen “Could not load multiboot modules: Boot image is corrupted”

    Going to try it with 5.0, but wondering if anyone had success with 5.1

  • ccbasubas says:

    I think we both are having the same problem, my motherboard was ASUS P8H61-M LE and having the same network interface Realtek 8111E.
    Have you got any solution already?

  • Paulus says:

    Hi Arno, I have the same problem with my B75MA-P45. It is OK with BIOS v1.3, but NIC can’t find after I updated to v1.6. It should be caused by the NIC firmware have been updated at the same time and not supported by ESXi.

    Anyone have solution?

  • Deyan says:

    Hi, Can I have some help. Someone was run Esxi of notebook Dell n5110 – cpu i7 2670qm, 8GB ram? He doesn’t detect network adapter. I use tool but the result is the same. Something missing but I can not catch what it was asking for help. My network adapter is Realtek 8101E

  • Subhadeep Sen says:

    Really Great solution. Thanks a lot…

  • mag says:

    HP Compaq Pro 6200 and ESXi 5.1 updated , OK :)

  • Brian says:

    No problems on a Lenovo T430 with ESXi 5.1U1. Thanks for the solution!!

  • Karthik says:

    Hi Everyone,

    It worked like a charm ,I have a system Intel Z77GA-70 which has Intel 82574 and Intel 82579 NIC , Intel 82574 was recognized with the default esxi5 update 2 , I used the above steps and It works great both my nics are recognized now .

    Thanks for the Tip

  • leo says:

    where can i download the vib file?

  • Claes Welinder says:

    Just Like Keith Liew, I can’t rebuild the ISO.

    “Fatal Error: Error uncompressing OEM.tgz”

    I’m on a Mac, running Windows through Parallels. (Also tried VirtualBox)
    For original installer I use “VMware-VMvisor-Installer-5.1.0.update01-1065491.x86_64”

    Any help would be extremely appreciated! :)

  • Claes Welinder says:


    Logfile says:

    Incorrect command line
    [Thu 08/29/2013 20:17:08.02] !———————————————————————————–
    [Thu 08/29/2013 20:17:08.02] !– FATAL ERROR: Error un-taring OEM.tar!
    [Thu 08/29/2013 20:17:08.02] !———————————————————————————–
    [Thu 08/29/2013 20:17:08.02] Run: “C:\Documents and Settings\TDW\Desktop\ESXi-Customizer-v2.7.1\tools\MsgBox.exe” 266260 “FATAL ERROR:&n Error un-taring OEM.tar!&n&nSee log file ‘C:\Documents and Settings\TDW\Desktop\ESXi_custom_ISO_NUC\ESXi-Customizer.log’ for details! Do you want to open the log file in notepad now?”
    [Thu 08/29/2013 20:17:18.91] Cleaning up …
    [Thu 08/29/2013 20:17:18.93] Run: rmdir /s /q “C:\Documents and Settings\TDW\Desktop\ESXi_custom_ISO_NUC\esxicust.tmp”
    [Thu 08/29/2013 20:17:19.05] This is the end.

  • maxmar69 says:

    Is it possible to use intel 82541PI with esxi 5.1 ?
    The kernel can see it (lspci shows it) but its not available on gui.
    Can you tell me where can I download a vib file for that nic ?
    Thany you

  • Fred Beck says:

    For 5.5 you can no longer use .tgz files (Deprecated) You can use this application with .vib files and it worked just fine. I picked up the intel 82579 drivers here http://files.v-front.de/net-e1001e-1.0.0.x86_64.vib

  • Zulfikar says:

    Thank you very much…this solution was save my money ..!!

  • mshajib says:

    Thanks a lot. I have done this successuly

  • Evandro says:

    Fred Beck says:
    11/11/2013 at 17:28
    For 5.5 you can no longer use .tgz files (Deprecated) You can use this application with .vib files and it worked just fine. I picked up the intel 82579 drivers here http://files.v-front.de/net-e1001e-1.0.0.x86_64.vib


  • Gal says:

    i have the same issue with 5.5 and dell R620.
    how can i tell which driver are needed??

  • Monty says:

    Brilliant! This worked perfectly for my Intel 82579V integrated nic on an Intel DH77EB motherboard. Thanks for this and all your hard work!!

  • Ken says:

    Have this, any hints on a driver that would work esxi 5.1

    Realtek RTL 8106E-CG on the motherboard.
    Esxi 5.1 will not recognize the adapter.

  • Pingback: Intel X79 whitebox for vSphere 5 and Hyper-V 3 - www.ivobeerens.nl

  • Justin says:

    I am new to VMware ESXi server, I try to install VMware-VMvisor-Installer-5.5.0.update01-1623387.x86_64 in intel DZ75ML-45k, Intel(R) 82579V Gigabit Network Connection, Every time it show the error “Physically Network Adapter Not Connected……’ and i try ESXi-Customizer too with many variant of .vib file, .tgz and offline_bundle But i can’t install the ESXi server, Pl anyone help me.. Thanks in advance…..

  • Will Zhao says:

    Fred Beck says: 11/11/2013 at 17:28 For 5.5 you can no longer use .tgz files (Deprecated) You can use this application with .vib files and it worked just fine. I picked up the intel 82579 drivers here http://files.v-front.de/net-e1001e-1.0.0.x86_64.vib – See more at: http://www.ivobeerens.nl/2011/12/13/vmware-esxi-5-whitebox-nic-support/#sthash.MzFkdTfp.dpuf

    This works fine for me with ESXi 5.5 CU2, It’s very great! Thank you in advance!!

  • Pingback: VMware whiteboxes can exceed the HCL limitations | iammarkharrison

Leave a Reply

Your email address will not be published. Required fields are marked *