VMware ESXi 5 whitebox NIC support

I tested the NICs below in my VMware ESXi 5.x whitebox server at home. Here the status:

NIC Recognized by VMware ESXi 5 Listed in ESXi 5 as
Intel PRO/1000GT Desktop Adapter PCI Yes Intel 82541PI Gigabit Ethernet Controller
Realtek RTL 8111E Yes Realtek 8168 Gigabit Ethernet
Intel Gigabit CT Desktop Adapter PCI-e Yes Intel Corporation 82574L
Intel 82579 Gigabit LAN controller No

You need the make a customized ESXi 5 ISO or VIB file.
This is a not supported configuration!
Intel Corporation 82579V orIntel Corporation 82579LM

To add for example the Intel 82579 chipset, create a customized ESXi 5 ISO.  This is very simple because some people have already done the hard work.

Here are the steps:

1. Download ESXi-Customizer (create by Andreas Peetz) found here.

2. Download the driver (created by Chilly) found here.

3. Start the ESXi-Customizer and follow the 3 steps:

2011-12-04 17h03_20

And you’re ready to create the customized VMware ESXi 5 ISO. The ISO supports the Intel 82579V and 82579LM NIC(s) found on many whitebox motherboards today.  Possible future updated version(s) of the driver can be found in the following post.

 

82 thoughts on “VMware ESXi 5 whitebox NIC support”

  1. had the same problem using a Intel DQ67SW motherboard with a i7 2600 cpu

    downloaded customizer 2.7

    tried it with VMware-VMvisor-Installer-5.0.0.update01-623860.x86_64.iso

    gzip the E1001E.tar file and renamed it to .tgz

    customizer gave a message saying “Adding a TGZ file to a ESXi 5.0 is *deprecated*
    Ask the source to file to provide a VIB file or Offline bundle instead

    I clicked on Yes to continue and it did build a custom iso but when I tried installing it I got the same message as before

    “No network adapters detected”

  2. Above instructions works ok.

    just rename tar file to tgz file otherwise you get the same error.
    I have gigabyte x79-ud03 with NIC intel 82579v

  3. To Joe:

    I FINALLY fixed to “no boot device found” error. I also have a similar Intel Desktop Motherboard (DH67) and I was going crazy trying to fix this issue.

    All you have to do is go into the BIOS (F2), Boot -> UEFI Boot -> Enable.

    I am running version 0155 of the BIOS, just in case.

    Carlos

  4. Works fine with a 82577. I now have a esxi 5 demo on a lenovo T520 laptop. Thanks for the great work.

  5. Works with Intel DH67BL Motherboard (Intel 82579V Gigabit Ethernet Controller). Fantastic post!

  6. After customizing the ESXi 5.0 iso and the intel driver DH67BL Motherboard (Intel 82579V Gigabit Ethernet Controller) i get this error when i reboot ..
    Missing operating system from the usb .. wondering what seems to be the problem ..

    downloaded customizer 2.7

    tried it with VMware-VMvisor-Installer-5.0.0.update01-623860.x86_64.iso

    gzip the E1001E.tar file and renamed it to .tgz

    customizer gave a message saying “Adding a TGZ file to a ESXi 5.0 is *deprecated*
    Ask the source to file to provide a VIB file or Offline bundle instead

    I clicked on Yes to continue and it did build a custom iso but when I tried installing it I got the same message as before – missing OS

  7. Can anyone help me .. Please i really need help to fix this .. i have been struggling alot .. Appreciate

  8. Hi,

    I have Pentium 4 processor with 102 mother board and realteck nic card. So with version(Customiztion) supports for these requirements.

    Thanks in advance

    Kondal Thummeti
    9849368495

  9. Hi all,
    this worked perfectly well for me on an Intel DH77KC Desktop mainboard, which features an Intel 82579 Gigabit LAN controller. This NIC is recognised and runs seamlessly. The only thing I had to change in BIOS to make the box boot was to enable UEFI-boot, which is disabled by default.
    Thanks for the great work!
    so long, Thomas.

  10. Muito obrigado!!! Economizei um bom dinheiro, não tendo que comprar uma nova placa de rede!!!

    Um grande trabalho realizado por vocês!!!

    Processor: Core i5 2400
    Motherboard: dh61wwb3
    Network Intel: 82579v

  11. This worked great for me in 5.0, but now that 5.1 is available for download, I tried to use this on the 5.1 ISO.
    It installs just fine, but when I reboot after the install (using an Intel DH67BL motherboard which has the 82579 on it), I get “could not load multiboot modules: boot image corrupted”.

    Does the customizer tool need to get updated for 5.1 maybe?

    Or is this user error… 🙂

  12. Hi Joe, are the Intel 82579 NICs working out-of-the-box with ESXi 5.1? So without customizing anything =) Thanks!

  13. @Rene, no the Intel 82579 don’t work out-of-the box with ESXi 5.1. I just tried the steps above with the 5.1 ISO and it works like a charm. Just ignore the deprecated warning 😉

    Great work guys.

  14. Hi Jeroen, well the only thing that’s keeping me from using this method that an in-place upgrade is not possible anymore, right? Or is there a way to inject the driver into the depot .zip file? Upgrading when using this method will put me into a state that no connection is available to ESXi =]

    Thanks!

  15. i use the computer Acer M4610G, so i check the network card is intell (r) 82579LM gigabyte network, and i follow you to customized it can know driver of 825779LM but after finished install it cannot boot with error “ERROR: no boot disk has been detected or the disk has failed”.
    i try many thing but is doesn’t work. i have select first of UEFI. anyone can help me??

  16. Same issue as Joe… ‘ boot image corrupted’…
    Worked fine for ESXi500, ESXi510 gives ‘boot image corrupted’…
    Is this a user error or does it need the tool to be updated??

    Thanks!

  17. Thanks a lot for the info. It worked for me. I was using Lenovo M Series (with 8GB RAM) and was having 82579LM NIC card. You guys rock!!
    Thanks again.

  18. Thanks m8, worked on Lenovo ThinCentre M91p workstation with Intel Q67 driver which is 82579LM. If you get a warning “deprecated blah blah”, just ignore it as Jeroen said.

  19. i have installed ESXi 5.1 it was working great suddenly i get a error message while booting ESXi as “could not load multiboot modules:Already exsist” Anyone pls give me solution to solve this.

  20. I was very lucky. When building my 5.x box, I took a gamble at the local computer store and bought a StarTech ST1000SPEX NIC (PCI Express (x1), Gigabit card) and ESXi recognized it right away (no mods!). Best $35 I’ve spent in awhile.

Leave a Comment